1

On Friday, out of the blue...no admin changes had been made, our page layouts went on the blink. All but six fields have disappeared on the page. When you go to edit, the full page layout shows up, but in preview you can only see the same six fields (out about 20). If you add or delete fields there are no changes in preview, although I can remove and add any one of the six fields. Starting a new page layout from scratch doesn't help either...only one of the six fields will show up when saved. Even stranger this impacts page layouts for Accounts, Contacts, etc. I can't find any one with this problem...any thoughts are greatly appreciated.

3
  • 2
    It sounds like your field level security got messed up. You'll need to check your field level security for each field. As for why it happened, I could hardly guess, possibly an admin playing around with a change set or Force.com IDE.
    – sfdcfox
    Commented Mar 11, 2018 at 17:59
  • 1
    Reviewing your Setup Audit Trail should help identify recent changes to your org and who made them.
    – David Reed
    Commented Mar 11, 2018 at 18:12
  • @fincann, Welcome to SFSE! and thanks for nice question Commented Mar 11, 2018 at 20:28

1 Answer 1

1

Since, when you edit the page layout all the related lists are available so here is the resolution to find the issues:

  1. User's profile should have access to the object and related fields.

  2. If user has access to the objects, even then he is not able to see the related list then only option is user may have removed the related list by his own way.

Basically, open the record detail page and find the Customize Page link.

customize page

Then in the below page, assign the related list in selected list side. Be sure to assign in the proper order. Because, this ordering overwrites the ordering the page layouts during display.

Customize My Page

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .