4

We have been using the 2nd Generation Developer Controlled Packages (https://developer.salesforce.com/docs/atlas.en-us.sfdx_dev.meta/sfdx_dev/sfdx_dev_dev2gp_plan_pkg_types_locked_unlocked.htm) in order to iterate on builds for testing our Lightning Components.

Today we ran into an issue when we tried to utilize a design:attribute (https://developer.salesforce.com/docs/atlas.en-us.lightning.meta/lightning/components_config_for_app_builder_design_files.htm) and it worked fine in our scratch orgs.

However, when we went to upgrade the package in our target Sandbox org by doing a sfdx force:package2:version:create and sfdx force:package:install, the design component never appeared in the Lightning App Builder, despite being present in the Sandbox org's Developer Console.

Is this a known limitation of package upgrades? Or am I missing something?

  • I'm using Package2 with design attribute and it's working. Can you create a new Package2Version to be sure it's not something that was fixed since you tried ? And then post some of your code maybe if it's still not working ? – Fabien Taillon Mar 20 '18 at 12:39
  • Right - so it still isn't working. I posted a slimmed-down version of my code in this gist - like stated initially, this works in scratch orgs when i use sfdx force:source:push but does not work when installing packages to a Sandbox org using package2 – Andrew Turgeon Mar 20 '18 at 16:20
  • Does it have to do with the fact that the package is Locked? – Andrew Turgeon Mar 20 '18 at 16:35
  • I'll give it a try. – Fabien Taillon Mar 20 '18 at 17:00
  • @FabienTaillon i was able to get this to work when I use the install URL -> test.salesforce.com/packaging/installPackage.apexp?p0=04t******** - seems there is some disparity between using the UI and the CLI? or maybe it was just a coincidence that the UI package upgrade worked? – Andrew Turgeon Mar 20 '18 at 21:46
2

We figured out the issue. Turns out the aura:attribute referencing the design:attribute needs to have access="global" in order to appear in the Lightning App Builder.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.