1

I created a data extension in my business unit and when I retrieve the rows from the data extension using the external key, it says the data extension does not exist. I tried using client ID In the request but still its the same. My request:

<env:Body>
  <tns:RetrieveRequestMsg xmlns="http://exacttarget.com/wsdl/partnerAPI">
     <tns:RetrieveRequest>
        <tns:ObjectType>DataExtensionObject[EXTERNAL_KEY]</tns:ObjectType>
        <ClientIDs>
           <ClientID>MyaccountID</ClientID>
        </ClientIDs>
        <tns:Properties>id</tns:Properties>
     </tns:RetrieveRequest>
  </tns:RetrieveRequestMsg>

I am not sure if my account ID and the client ID are the same. Because when I use the below request, account ID and client ID in the response are the same.

<tns:RetrieveRequestMsg>
     <tns:RetrieveRequest>
        <tns:ObjectType>BusinessUnit</tns:ObjectType>
        <tns:Properties>Name</tns:Properties>
        <tns:Properties>ID</tns:Properties>
        <tns:Properties>Client.ID</tns:Properties>
        <tns:Properties>AccountType</tns:Properties>
        <tns:Properties>BrandID</tns:Properties>
     </tns:RetrieveRequest>
  </tns:RetrieveRequestMsg>

I also need to know what is the difference between MID and client ID and how to get the MID of business unit. A sample soap request to get shared data extensions will be helpful.

I used QueryAllAccounts = true to list data extensions across all business units. But the data extensions I created in my business unit are not returned.

  • What are you using for authentication? (Not an aside, this actually matters). Are you getting a token via REST and using it for your SOAP call (preferred, by the way). Or is it username/pwd ? – Timothy Mar 2 '18 at 16:30
  • @Timothy I am getting a token via REST and using it in SOAP call. – Chandra Prakash Mar 5 '18 at 4:32
  • OK, so next step: REST tokens are BU specific. Is the MID you are using for the parent (top level) or the child BU? If you don't know, log into the SFMC and have a look. – Timothy Mar 5 '18 at 16:00
  • @Timothy I tried with MIDs of both the child BU and parent. Its still the same. – Chandra Prakash Mar 7 '18 at 11:10
  • Have you gone through this thread? salesforce.stackexchange.com/questions/132602/… – Timothy Mar 7 '18 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.