3

There was a new critical update named "Remove Instance Names From URLs for Visualforce, Community Builder, Site.com Studio, and Content Files". But after active it, all of the Tabs which contains a Visualforce Page could not be shown on one/one.app when display with the Safari browser on the iPhone.

To make sure this issue was not caused by any other reason, I created the following simple Visualforce Page

<apex:page >
    <apex:outputPanel id="output">Test Page</apex:outputPanel>
</apex:page>

And I also make it be "Available for Lightning Experience, Lightning Communities, and the mobile app" Then I create a new Tab and also I add it in the Salesforce Navigation in Mobile Administration.

When I deactive that critical update, I can see the text "Test Page" when I click my sample Tab. But unfortunately, it shows nothing after I active that option.

Why? Anybody else meets the same probelm with me?

I have posted a question on the developers forum, and I want to post it here to seek for more help.(https://developer.salesforce.com/forums/ForumsMain?id=9060G0000005TyBQAU)

BTW, I also noticed that when the problem occurs, there were several errors reported in the console, several 404 errors and also a strange "Failed to load resource: too many HTTP redirect" error.

  • I noticed the following change after Winter' 19 update. Now in the given case, the Visualforce Page could be shown (But strangely, the page will reload twice) But after the page shown, I notice the JS code referenced by the VF component does not load correctly. When track with the resource request, we noticed the server returned a strange HTML content when request the target .js file. – Leo Li Nov 14 '18 at 3:37
0

One thing I have noticed: After deploying this update it takes some time (an hour or so?) to work properly everywhere. In the meantime I get some funky redirects. Afterwards, everything works smoothly. If you tested immediately after enabling the Update and panicked, that might explain it.

  • Not really works for me. I changed the setting several days ago, and also I tried to clear the cache for Safari on iPhone, but it does not help. – Leo Li Feb 26 '18 at 8:56
0

I have also faced similar issue after enabling the update. Please follow below steps and see if it works:

  1. Enable the critical update
  2. Logout from Salesforce
  3. Clear browser cookies
  4. Close browser
  5. Login again and access any custom VF Page

It worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.