I'm currently using CentOs 6.9 and I'm trying to run the program Salesforce2Hadoop on Terminal. When I run the initial data import using the init command, I came across this error:

Exception in thread "main" [LoginFault [ApiFault
exceptionMessage='Invalid username, password, security token; or user
locked out.'

My login credentials are correct as I am able to log into the web version of Salesforce and verified the environment via Eclipse. What am I doing wrong?

I'm also running the latest version of wsc as well.

  • Have you tried adding in your security token?
    – Adrian Larson
    Feb 21, 2018 at 19:43
  • I did with same error @AdrianLarson
    – Shad
    Feb 21, 2018 at 19:55
  • 1
    Did you see the failed login attempts in the login history for the user? If not, my first thought would be a mismatch between production and sandbox orgs. They need different login URLs. Feb 21, 2018 at 20:30

2 Answers 2


If you can get in via Eclipse (so I assume you've included your IP address in the trusted list), and can get in via the web (so your username and password are correct), the most likely problem is that you didn't include your security token after the password when logging-in. Having said that, I realize that you seem to be attempting to log in via Terminal, which may be from the same IP address as Eclipse.

Also, check the login history on your user record via the web, to see if anything else is listed, and to see what the IP addresses are.

  • Just reset my security token & received the same error. I also checked my login history & saw that I was able to login today to an "other APEX API" at the same IP address I'm using for Firefox (the broswer I used to log into the web app.
    – Shad
    Feb 21, 2018 at 19:55
  • Now that you've reset your token, did you need to update your Eclipse credentials as well? Feb 21, 2018 at 19:58
  • It ran when I changed my security token in Eclipse.
    – Shad
    Feb 21, 2018 at 20:08
  • Good. Then Eclipse is working fine, and your token is working fine. That means that something in the authentication methods in your application is wrong. Sorry - not what you wanted to hear, I'm sure. Looks like the Hadoop2Salesforce app might be having problems in its code. Feb 21, 2018 at 20:10

If you have a special character in your password that could be the issue. I ran into this scenario when trying to access the API through Postman. I could login to the web just fine but when trying to access content through the API it gave me an invalid login error.

Finally figured out that because my password contained an # symbol, it needed to be encoded. So I had to use %23 instead of #. I know this is a bit different but maybe it will help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.