In a Lightning Components Developer Guide there are two
inputFields - [one] in a
force namespace and a [second] in a
lightning namespace. Looks like both of them serve the same purpose (being an input field) but their functionality just differs a bit.
I can undestand a reason why there are two types of input fields for both the Lightning Components and Visualforce Pages since they are parts of kinda different frameworks, but can someone explain me why it couldn't be one
inputField for a Lightning and they decided to split it on two and put into different namespaces?