4

I am working on POC and evaluating platform events feature for our near real time integration. I have create an event and trying to test it with workbench. Some thing like shown in this video https://www.youtube.com/watch?v=L6OWyCfQD6U ar around 17:14.

But i am not able to subscribe and dont see any updates on my screen. Here is screen shot of my workbench after i press Subscribe button. enter image description here

Same steps are mentioned in documentation as well. But for some reason its still not working.

Here are things i have already tried:

  1. The Event name and Chanel name is verified "/event/CaseEvents__e"
  2. Streaming setting in Enabled in Setup -> User Interface
  3. Tried this with both API version 40 & 41

Please let me know if I am missing anything. Thank you.

  • Seems like Workbench is cooked, looking at JS console you'll find Uncaught Illegal state: already disconnected – dzh Mar 3 '18 at 4:09
3

I spent a lot of time banging my head against this as well. I finally realized that in the video, the presenter is using https://workbench.internal.salesforce.com (v42.0.0i) instead of the publicly-available https://workbench.developerforce.com (currently v41.0.1). Even though he's hitting API 40, he's on a newer version of Workbench that must do a better job of listening for Platform Events.

Hopefully they release a new version of Workbench for the rest of us soon. I'd really like to be able to test my code without jumping through crazy external hoops.

  • Interesting, on my local instance it worked too.! – AtulRajguru9 May 4 '18 at 9:52
  • 1
    FYI - Salesforce just updated the workbench to v42 and it can now listen for platform events. – Drew Tauber DrewCPU May 30 '18 at 15:25
0

It worked for API version of 37 for me. I guess it works 39 under in workbench.

  • Interestingly, 37.0 is not officially supported either. – Adrian Larson Apr 21 '18 at 15:11
0

Have a look at this page in the Streaming API Developer Guide:

Subscribe to the PushTopic Channel

...

Workbench supports Streaming API in versions 36.0 and earlier only.

  • Thank you for the link. Can you please share what exactly your thoughts are? I had already tried API version 40+ . If your point is not using is for production then I am not. – AtulRajguru9 Apr 21 '18 at 15:56
  • Did you read it at all? 40+ is clearly later than 36.0, the latest supported version. – Adrian Larson Apr 21 '18 at 16:07
  • I read the link did you read the question before posting link only answer? if you know why its not working then please explain or leave it to someone who knows the answer. – AtulRajguru9 Apr 22 '18 at 13:42
  • How is it a link only answer...did you read my answer at all. Workbench supports Streaming API in versions 36.0 and earlier only. – Adrian Larson Apr 22 '18 at 14:00
  • 1
    Did you check the video in question.... @ around 13 minute it shows that api version is 40 and its worked there. – AtulRajguru9 Apr 22 '18 at 17:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.