I have created a new sfdx project and pulled source from a managed package. When I try to push the source to a scratch org I get

ERROR:  Cannot read property 'getAggregateFullNameFromFilePath' of null.

I have never seen this error before and was not able to find anything while Googling around. Has anyone ever seen this error or know what that property is?

  • 3
    I've seen this on existing projects where SFDX somehow gets into an inconsistent state, the remedy being to delete all the project cache files and sometimes reinstall SFDX. I'm not sure that applies with a new project.
    – David Reed
    Feb 15, 2018 at 20:17
  • Okay great I will give that a try Feb 15, 2018 at 20:19
  • 1
    I have also seen this only recently - for me deleting .sfdx worked. Feb 15, 2018 at 20:23
  • Another option: check you don’t have a lightning component with a <style> attribute in it being in API 42. This tag has been removed in Spring. Feb 15, 2018 at 22:13
  • FWIW, I had this error and it turned out to be a syntax error in the JS controller fo a lightning component. However, the only way I realised this was to recreate each component manually in a scratch org, copy the code across, and then save it (eventually one failed, and fixing it solved the problem.) I only had around 10 lightning components though so this was annoying, but feasible. If you have hundreds then not so much...
    – berry120
    Feb 16, 2018 at 16:08

2 Answers 2


I got this error recently.

I found a corresponding failed deployment in the scratch org by a quick find for "Deployment status" in setup.

Please look there for details on failure.

  • 1
    This does not provide an asnwer to the question, please make sure you ahve enough rep in order to be able to leave comments son posts. To do so, participate in the forum and please review How to Answer . thanks!
    – glls
    Feb 16, 2018 at 16:06
  • 1
    The answer does provide valuable info. If you get getAggregateFullNameFromFilePath on the command line, go to your Scratch Org and check the Deployment Status. Feb 19, 2018 at 11:30
  • 1
    Thanks Christian Szandor Knapp. Checking the deployment status provides valuable info on the failure - like which component or class failed to deploy. I was able to address the root cause of all my failures by following this approach.
    – Rajesh
    Feb 20, 2018 at 15:15

We have the same error, and the reason was a syntax error in one of the lightning components. We are working with VS code and we had this error by pushing to scratch org. The reason was a simple syntax error: we wrote <aura:attribute name"theName" type="something"> instead of <aura:attribute name="theName" type="something">

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.