I am trying to create a calendar event using Process Builder whenever a task is created.

I am passing the parameters as shown in the screenshot, but get an error like

" FLOW_ELEMENT_ERROR This error occurred when the flow tried to create records: REQUIRED_FIELD_MISSING: Required fields are missing: [DurationInMinutes]"

Tried different combinations of start date time, end date time and duration but always get this error message. Any help to fix this issue is highly appreciated. Thanks in advance!

enter image description here


Use End Date Time as Now() + (60/24/60) which is 60 minutes.

According to your post Now()+1 is 1 day and not 1 hour.

Following process works for me


|improve this answer|||||
  • Hi Santanu Thanks for your message. Tried changing End Date Time as you mentioned, but still get the same error. Also removed Duration and kept just the start date time and end date time. Tried keeping only the Start date time and Duration and removed the End date time. But always getting the same error. – vivin mathew Feb 14 '18 at 4:14
  • updated my workable process with screenshot – Santanu Boral Feb 14 '18 at 4:36

Sorry it was my mistake. Had another Process builder trying to create an Event and that was causing the issue. Deactivated the other Process Builder and its all good now. Thanks!

|improve this answer|||||
  • you should close your question, and mark as answered. or delete it – Saariko Mar 16 at 4:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.