6

I am trying to upsert to Salesforce using PartnerConnection SOAP API. I have no records in my custom object and get the following error when I upsert a new record:

Master Encryption Key 1 has already been deleted

I have another cloned sandbox and is able to upsert without any errors. Maybe refresh my sandbox?Any other suggestions what the problem may be?

  • Any suggestions?I need to get it working else I have to open a support ticket :( – Thys Michels Nov 20 '13 at 19:21
  • Do you have any triggers on your custom object? I don't think I've ever seen that error come back from the Partner API. – Daniel Ballinger Dec 19 '13 at 7:23
  • Not sure if support helped you resolve this or not, but it seems you may have encryption enabled in that sandbox, or did when you created the wsdl, and now, the encryption key has been deleted, or was never created. – JimRae Dec 29 '13 at 14:01
  • There's not a chance that you're upserting with the Id of the deleted object is there? – Matt Lacey Jan 16 '14 at 0:55
1

The error message: Master Encryption Key 1 has already been deleted is returned when you try to access encrypted data on the platform that can't be decrypted because the master key has been deleted.

My initial thought was that you are getting the error because you're querying or updating a record that was encrypted with a deleted key. However since you have no data for this object type in your org, that wouldn't be the case.

Another thing to do would be what @Daniel Ballinger mentioned. Check that no other objects are referencing your object during the upsert. This could be anything from another object being queried during a trigger, a lookup relationship, a summary field, etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.