2

I have an external service that I would like to offer on Salesforce via their marketplace.

As I understand, I need to create a Connected app and use the oAuth APIs to connect to the Salesforce system. Once I have this setup, I can create a Package and distribute it in the marketplace.

I'm going through the paces, trying to make sure my assumptions are correct (is there anything I'm missing?).

However, I ran into a problem

  1. I've created a Connected App entry in the App Manager and it shows up as 'Connected'
  2. I've created a package in the Package Manager and it too shows up properly
  3. I open the Package Manager and go into Setup, but I can't add the Connected App into the Package.

When I select 'Apps' from the dropdown, my Connected app doesn't appear. Do I need to do something else for the app to appear?

Package manager view

  • 1
    Strictly speaking, this method of installing connected apps is obsolete; the first time a user in an org uses it, it automatically appears in the Setup menu, and can then be installed/configured/blocked by an administrator. – sfdcfox Feb 12 '18 at 17:23
  • Is your org namespaced ? – Mohith Shrivastava Feb 12 '18 at 17:24
  • @sfdcfox So how do you distribute the app on the Appexchange without packaging it? I want the app to be listed there, – JohnP Feb 12 '18 at 22:18
  • @MohithShrivastava I don't think so. Is that required? – JohnP Feb 12 '18 at 22:18
  • @JohnP Yes please .Check my answer .You need to namespace and then create a managed type of application . – Mohith Shrivastava Feb 12 '18 at 22:27
1

Aren't connected apps listed in the "Connected App" component type drop down menu not the "App" one.

You just need to switch the drop down.

  • Actually, you're partly right! The 'Connected App' option doesn't seem to show up till you set the namespace as described here : developer.salesforce.com/docs/atlas.en-us.lightning.meta/… Once you do setup the namespace, the Connected App option shows up and you can select it and the app appears. Thanks! – JohnP Feb 23 '18 at 15:51
  • I had the same issue but a little bit different. I marked the package as 'managed' but get the error message that I is not possible to have more than one managed package in one Org (but I had no other managed package in this org). When I do not select it as a managed package the Option 'Connected App' do not appear in the drop down. So the solution was: Do not mark it as 'Managed package' on the first step-> add all other relevant components and than on the next screen edit the package again and mark it as 'Managed package'. And...The menu appears in the Dropdown – utm Nov 23 '18 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.