1

We have a lot of automated emails set up in Marketing Cloud which are used in journeys, triggered sends etc. Most of them are built in Content Builder.

We came in this morning to find several journey sends had errored, and upon inspection we found that the Ampscript we have used in our emails has broken. For example, one had gone from this:

%%[VAR @sl, @firstName, SET @firstName = ProperCase([firstName]) SET @sl = Concat(@firstname,", ","take a look at the line-up!") ]%% %%=ContentBlockbyId("40211")=%%

To this

%%[VAR @sl, @firstName, SET @firstName = ProperCase([firstName]) SET @sl = Concat(@firstname,", ","take a look at the line-up!") ]%% %%=ContentBlockbyId("40211")=%%

As you can see, it's turned all single and double quotes into ".

Yesterday these were fine, but when we came in today, basically every email we have ampscript in has suddenly gone this way. You can edit it and put it back to how it was, but as soon as you go back in to edit it again, it's like Marketing Cloud 'fixes' it and puts it back again, meaning none of our emails are currently deploying because this is breaking the code.

Does anyone have any experience with this happening?

  • Looks like many had similar issues: success.salesforce.com/…. Please refer the link: success.salesforce.com/… where some workarounds are provided – Ganesh Kumar Feb 9 '18 at 0:49
  • @TCassa I have a feeling it is the content builder 'content' window which formats the ampscript code as html code. In this scenario you should be putting your ampscript within the code editor window. – Brad Sapkota Feb 9 '18 at 1:08
  • Thanks both. However this has suddenly started affecting emails which have been working for months, rather than something not rendering as I am trying to build it. – TCassa Feb 9 '18 at 9:10
4

I started having the same issue yesterday. I spoke with Marketing Cloud Support this morning. This is a known issue in the latest release with freeform and text blocks in Content Builder that causes things to be switched to the HTML encoding.

Their temporary workaround is to remove the freeform and text blocks and replace them with HTML blocks. I've tried this and it seems to solve the problem for now.

My support agent said it looks like a hot fix is in the works for next week to resolve this. I'm now going through all my upcoming Journey sends to replace the content blocks to try to work around this.

1

WYSIWYG content blocks be damned!

Much to the dismay of those allergic to HTML and AMPScript, I refuse to configure emails that use them. This is a case in point.

Plus if you've ever tried to edit code that's been "formatted" automatically, you know how much of a pain it is.

0

Thanks folks, glad we're not the only ones. Spoken to our support agent and there's a fix coming Wednesday.

In the meantime, if you're working this weekend, you can go in and replace the corrupt ampscript with your corrected ampscript, and save it, and as long as you don't click the block to edit it again, it should deploy fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.