5

I'm having trouble deploying to a sandbox. Profiles have been a pretty major pain, so I simply removed all profiles from the mdapi output dir. Now I am fighting QuickActions. In each of my layouts I am getting this error:

In field: QuickAction - no QuickAction named NewEvent found

If I fix that by removing the QuickAction in the deploy dir, then it just moves on to the next QuickAction and throws an error about that. These are standard QuickActions, right? How can I get those to just deploy without removing all references in the layout?

I saw an earlier post about emails, and it mentioned making sure my API version was at least 28.0, and I am using 41.0. So I know it isn't that.

1

Do you have translations? Sometimes if things get out of sync the translations can throw these errors. If you can, delete out the translations for the object, or at least make sure that they’re all in there.

Specifically, page layouts all get translated, and if the page layout translation is wrong, the whole thing fails to deploy.

|improve this answer|||||
  • hi there just wondering: do you also often find SFDX missing sync? I find myself getting metadata dependency errors often – Atlas Can Nov 27 '19 at 2:00
  • 1
    @atlas-can - It definitely seems better at catching some changes than others. Page layouts and translations in parrticular seem to be a challenge. – Allison Letts Nov 27 '19 at 3:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.