0

I am getting below error when migrating profile from SIT to UAT.

Error: Unknown user permission: ApexRestServices

SIT:

enter image description here

UAT

enter image description here

  • 3
    ApexRestServices seems to be introduced in winter 18. Are your SIT and UAT in same version? – Raul Feb 1 '18 at 17:08
  • Nope. They're not of same version. Any suggestion how we can fix this out ? – Kanika Feb 4 '18 at 17:12
  • Are you using changeset for deployment? If the setting is enabled in source org and is enabled, tried deploying while deactivating that setting? – Raul Feb 4 '18 at 17:56
  • Nope, its using ANT migration tool – Kanika Feb 4 '18 at 18:06
0

Just had the same issue via a metadata upload. Since your orgs are on different versions, you are going to need to deactivate that value in the .profile file.

Remove the following:

<userPermissions>
    <enabled>true</enabled>
    <name>ApexRestServices</name>
</userPermissions>

Then you should be all set. Make sure to verify if this got added automatically or if you modified the setting for a reason.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.