0

I am trying to generate access token using Fiddler and results in error

HTTP/1.1 400 Bad Request
{"error":"invalid_grant","error_description":"authentication failure"}

The same request I tried from the POSTMAN and its working fine.

Below are the steps that I am following in fiddler :

METHOD: POST

ENDPOINT URL : https://test.salesforce.com/services/oauth2/token

REQUEST BODY client_id={Client-ID}&client_secret={Client-Secret}&grant_type=password&username={UserName}&password={Password}

*NOTE - However, I observed that when the same request I hit from POSTMAN and consecutively later from Fiddler it is generating the access token. Although if I hit the same request independently from fiddler its results in above error.

4
  • Did you try adding the security token to password?
    – Prasanna
    Jan 25, 2018 at 7:37
  • @Prasanna Yes we tried that too Jan 25, 2018 at 7:53
  • Does external system required any IP WhiteListing ? Jan 25, 2018 at 12:20
  • @NachiketDeshpande: IP is already whitelisted. Jan 25, 2018 at 12:27

0

You must log in to answer this question.

Browse other questions tagged .