I configured a Data Extract (Data Extension Extract) and a File Transfer (Safe House to External FTP which is also an SFMC FTP ). Unfortunately, File Transfer fails without giving a proper error.

ERROR: An undefined error occurred. Contact your account representative if the error persists.

Salesforce Support is asking me to whitelist Stack 1 IP Address on my Internal Network when the operation is done within SFMC Servers. I have ask them to escalate this to Tier 2 support.

Have you come across this issue in the past? What have you done to resolve this issue?

2 Answers 2


Marketing Cloud Tier 2 told me that the exception at backend is "FTPOutputProtocol: ReadFrom failure (attempt #1) - No such host is known ". This was related to my File Location configuration.

In File Locations, URL should be "ftp://ftp1.exacttarget.com" instead of "ftp1.exacttarget.com" which was configured by me. I was transferring a file from a child BU to Parent BU and once I updated the File Location URL, it worked fine.

For other stacks, FTP url are mentioned below.

ftp://ftp1.exacttarget.com if your account uses the S1 instance

ftp://ftp.s4.exacttarget.com if your account uses the S4 instance

ftp://ftp.s6.exacttarget.com if your account uses the S6 instance

ftp://ftp.s7.exacttarget.com if your account uses the S7 instance

ftp://ftp.s10.exacttarget.com if your account uses the S10 instance

Documentation for Enhanced FTP is here.


It would be very strange that you'd have to whitelist IP in your internal network if you are trying to transfer between two SFMC FTP server.

Try extract, then file transfer (upload) to the export folder of the FTP. Then do a file transfer from your FTP to your external FTP server.

Transferring in/out if a Salehouse is used for internal system transfers, I suspect it wouldn't allow you to transfer from a Safehouse directly to a foreign FTP server, you'll want to do it in steps of exporting it to Export folder and then Transfer to foreign.

Give it a test and let me know

  • Tried it and its still giving me the same error. The case is escalated to Tier 2 support and i am hoping they will come back with a solution. will keep you posted. Commented Jan 29, 2018 at 4:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .