1

I have been trying to parse a WDSL file for Exact Target and also in SFDC, but I get an error that it is not allowing me to generate the apex classes I need.

Error: Failed to parse wsdl: Parse error: Found invalid XML. could not determine namespace bound to element prefix xsd (position: END_TAG seen ...... @33:13496)

When I tried running in Validatot this is the error I'm facing

Unable to parse any XML input. Error on line 9: The prefix "xsd" for element "xsd:complexType" is not bound.

The WSDL I'm trying to Parse is from this link Link

Help please

1

Please use http://www.fuseit.com/contact/downloads/fuseit-sfdc-explorer/ to generate the apex classes. Please download it and log in to it by using your credentials. Then navigate to wsdl2apex tab and specify the WSDL file. After generating the apex classes, please use the "Deploy All Apex Classes to Salesforce" button to deploy the apex classes to your Org.

I have deployed it successfully to my dev org using the Fuseit SFDC Explorer.

|improve this answer|||||
  • I can able to edit the class but unable to view. Getting this error when I'm try 'An internal server error has occurred'. Is anything missing – Eagerin Sf Jan 25 '18 at 15:15
  • Yes, I am getting the same error. But I tried some other WSDL to see whether the internal error is coming or not. Is it working while making the call? Just try calling this Apex class and look at the results. I am not sure about the error. – Prolay Chaudhury Jan 25 '18 at 17:04
  • If you view the Apex Class in the Fuseit SFDC Explorer, it is getting shown correctly and also getting deployed successfully. I am wondering why it is giving the error. As per Salesforce Governor limit on the Apex class size limit, it is 1 million, and the total characters of this class are 789096. – Prolay Chaudhury Jan 25 '18 at 17:58
  • If the apex class size is problematic you can chose which specific web methods you want code generated for and generate a smaller class for just those. – Daniel Ballinger Jan 26 '18 at 8:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.