2

I have shared all opportunities (read only) to a certain role in the organization and can confirm they can definitely see all the opportunities by going to the record's physical page. However, when they run a canned report we created for them, they do not see all the company-wide opportunities, they see only those owned by users in their own role and below. Am I missing some setting which opens this up? List Views work fine, the actual page records work fine, but for some reason it seems reports default to role hierarchy and ignore sharing rules...

  • I can see the option for the user to "Show Hierarchy" then they can click the highest role ("President/CEO"), but that doesn't seem like a good answer. There should be a way to set this as default. When I (admin) go to the report, I don't have this option, so I'm unable to "Save Current Hierarchy"... – Nathan Williams Nov 12 '13 at 6:19
2

Turns out, we (admins) never assigned ourselves to a role, since we had global CRUD anyways. Once we set our own role to "President/CEO", all reports we created/saved from that point forward automatically saved as that hierarchy level, which solved our issue!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.