6

When I try to share a file in Salesforce, I get the error that

The maximum number of times this file can be shared has been exceeded

Which means it is shared > 100 times. The documentation indicates that

The maximum number of times a file can be shared is 100. This includes files shared with people, groups, and via links. If a file is privately shared and nears the 100 share maximum, consider making the file public by posting it to your feed.

But how do I do that? When post an existing file to my feed and then try to share it, it still throws the same error... How can I prevent this sharing error?

Note: the file was originally uploaded in a Library.

1 Answer 1

1

I don't know if this answers your question but here's a few ways to check if the file is public or not.

Go to Files tab > Search for your file > Sharing Settings

enter image description here

For the first option, Any user in your company should be set to Viewers. Now the file is available for all the users in your org.

There's no option of sharing when it is managed by a library.

To be even more sure that the file is available for all the users, go to the library in which this was uploaded and edit it, add the public groups in a way which will reveal it to a greater number of users. However, I can't test this case because am working a developer edition.

If this is not what you're looking for, upload the file in the Files tab and share it with everybody (1st option in attached image)

Here's a helpful query to see clearly, go to Developer Console > in Query Editor:

SELECT Id, LinkedEntityId, Sharetype, Visibility FROM ContentDocumentLink WHERE contentDocumentid = '>>Grab the id from the URL of the file, ex: 069f2000006slfS<<'

For reference: ContentDocumentLink

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .