Any idea on why it's giving an error Insufficient Privileges when I'm trying to import a key store (exported from another sandbox) ?

Importing/Exporting it as an System Admin, with or without password, it doesn't change the result

  • Simon, Would you mind marking the second answer (about alpha numberic passwords) as the best answer please? This solved the same issue that I was having at least. Feb 26 at 22:28

I ran into this and even though it says 'Insufficient Privileges' when exporting the JKS file, it turned out that it was only giving that error because the password was not alphanumeric. I had to add both letters and numbers into the password before it worked successfully.


I had similar issues, opened a case and here is the answer:

our R&D team has confirmed this is unexpected behavior and we have logged an internal issue record to address your case. I have marked your case as dependent on our internal issue.However we have a workaround in Lightning Experience by following steps:

Goto setup --> quick find --> look for certifcate and key managements Click on the button "Export to keystore" --> do not provide any password and click on Export --> The file is downloaded.

Or switch to classic and then try to Export using Keystore password.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.