3

Has anyone encountered this on v42.0 and if so, was there a resolution? I am overriding the "New" Case action with a Lightning component.

Strangely enough, when attempting to deploy to an org that org on API v41.0, the message is instead: objects/Case.object -- Error: Large is not a supported form factor.

In the Case.object metadata, here is the relevant action override section (you can see formFactor is indeed set to "large":

<actionOverrides>
    <actionName>NewCase</actionName>
    <content>CreateCaseCmp</content>
    <formFactor>Large</formFactor>
    <skipRecordTypeSelect>false</skipRecordTypeSelect>
    <type>LightningComponent</type>
</actionOverrides>

However, a value of "large" seems to be what the documentation for the actionOverride metadata requires for a lightning component override -

the Large value represents the Lightning Experience desktop environment and is only valid for the flexipage and lightningcomponent types.

1 Answer 1

4

I was testing and removing the <formFactor>Large</formfactor> line from the metadata allowed the deploy to succeed, and the override appears to be working correctly in the target org.

1
  • What tool did you use to remove the element from the XML? We tried using Copado, its Find and Replace Rule, with a Perl-based regex expression: (?s)(\n\s*<formFactors>Small</formFactors>). We also unsuccessfully tried to Find and Replace just the exact element <formFactors>Small</formFactors>. May 18, 2023 at 6:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .