8

I'm getting the following error when running any sfdx command with the latest version of the Salesforce CLI on macOS High Sierra:

Cannot set property color of #<CLI> which has only a getter

I've attempted updating and re-installing the Salesforce CLI but the error persists. No other output results from running any sfdx command other than the error message.

What could be causing this and how might it be resolved?

  • This is happening to me as well so maybe its a salesforce issue? I have been working all day and it just started – Zack Walton Jan 12 '18 at 21:18
12

We had an auto release with a bug. We've rolled it back. Please run sfdx update and ignore the one time error you receive.

The team is already performing a retro to understand how this got out.

Sorry for the trouble.

| improve this answer | |
  • I didn't do any updates recently and still was getting that issue. Anyways sfdx update fixed the issue – ashkanent Jan 12 '18 at 21:36
  • ...and the quick answer! – AlwaysThinkin Jan 12 '18 at 21:37
  • The CLI auto-updates itself. I believe you can disable this with export SFDX_AUTOUPDATE_DISABLE=true still, but be mindful of what you're missing out on. – Wade Wegner Jan 13 '18 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.