5

I am facing a problem when deploying a project to my scratch org. I have a custom object named Project Information. This object is accessible to admins and user and the permission is set using permission sets. When i try to execute sfdx:force:push -u ProjectMgmtScratch, i am receiving an error like this.

force-app\main\default\layouts\Project_Information__c-Project Information Layout.layout-meta.xml Invalid field:TASK.SUBJECT in related list:RelatedActivityList.

I haven't touched the Task object but still facing this error. Has anyone had issue like this?

  • Are there any differences between your settings on activities on your scratch org and any org you developed this code on? – battery.cord Jan 12 '18 at 14:20
  • I edited my object and unchecked Allow Sharing, Allow Streaming and some other checkboxes. In the sharing settings, I changed public Read/Write to Public Read only. I had pushed admin and other custom profiles before. I deleted those profiles from remote (origin/master) and that's all the change I made. I even created a new scratch org and tried pushing the project but unfortunately received Invalid field:TASK.SUBJECT in related list:RelatedActivityList error. – user51525 Jan 13 '18 at 1:45
1

I had to remove my duplicate rule and matching rule from my project. This might be a bug in salesforce(not sure).

I tried deactivating the rules but unfortunately could not deploy it. So, try deleting the matchingrule and duplicaterule folders.

Edit: don't forget to delete the references of these rules from sourcePathInfos.json and metadataTypeInfos.json. These files contain matching and duplicate rule paths.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy