0

I have a VF page which shows some status value in Home page. In my Org Clickjack is enabled and because of that my VF page is not shown in the Home page. Can anyone tell me how to override the clickjack setting or let me know any other alternative approach. I cannot disable the clickjack option because of the company policy.

2
  • Do you mean home of Salesforce classic view or in Lightning View?
    – Patlatus
    Commented Jan 16, 2018 at 16:34
  • @Patlatus yes in Home page I want to show a visualforce page which has all Case status.
    – Tamil
    Commented Jan 17, 2018 at 19:57

2 Answers 2

0

I had the same issue some time ago trying to embedded a vf page inside a Standard UI and made it work with below code. It worked in Classic and LEX

<apex:page standardController="Account" showHeader="false" sidebar="false" standardStylesheets="false" 
applyHtmlTag="false" applyBodyTag="false" docType="html-5.0">
Testing clickjack inside vf
</apex:page>
2
0

here is one workaround for this issue.

Go to the Session Setting, add the base domain of your org into the white-list domain, that should solve the problem.

For example, the base domain should be something like this:

https://yourdomainname.my.salesforce.com for classic

https://yourdomainname.lightning.force.com for lightning

Good luck~

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .