5

Iv'e created a flow that is embedded inside fsl app. Inside the flow App Extension I set it to run only on WorkOrder object. I need to use the record id inside my flow but i'm not able to get it.

I read the following:

"When the Field Service Lightning mobile app launches into a flow, it passes the following input parameters: – Id: The record ID of the record that the workflow is launched from. – ParentId: The record ID of the parent record that the workflow is launched from. For example, if a workflow is launched from a service appointment, this will be the ID of the parent work order or work order line item. – UserId: The ID of the current user."

I tried to create a variable inside my flow with the name Id (type - Text, input/output), but still, this is not working.

Hope someone can help me figuring this out ..

It's important to say that i'm using fsl configuration that are a bit different than the usual settings ..

Thanks !

2
  • I'm working on this, too - any progress?
    – Helpful
    Commented Feb 28, 2018 at 22:55
  • Any solution to this problem?
    – Enry
    Commented Feb 5, 2019 at 11:52

3 Answers 3

2

You have to create ja Text Variable called "Id" that is availavle for Input. enter image description here

Step two is, get the data that you want

enter image description here

The Varibale "Id" is the ID from the scoped Object in the Field Service Mobile Settings.

enter image description here

PS: FSL will work offline to, the App priming all records form the Service Appointment in this Case.

2
  • Thanks for the solution.. Id helps instead of recordId Commented Jun 14, 2023 at 4:27
  • @TruptiRajput Welcome to SFSE - no need for 'thanks' posts, just upvote the answer! :)
    – Matt Lacey
    Commented Jun 14, 2023 at 9:49
1

"Id" worked for me not "recordId" to fetch current record for Mobile service flow

1
  • If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context.
    – MnZ
    Commented Jan 19, 2021 at 7:19
-2

Create a variable called "recordId" exactly, not "Id".

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .