0

It works fine when I import the contact manually. But I can not send SMS to my test mobile phone(HK) when I use the Automation Import Mobile Contacts to a list. The Automation does two things: 1. SQL query from Sync Data Extension(DE) to an ordinary DE. 2. Import Mobile Contacts from the above DE to a contact list. Can not send SMS using this list. Can someone help me to troubleshoot it? Thanks in advance.

0

How does it import?

As in, what is the Status of the MobileConnect subscriber? Is the country code added? Is the number subscribed to a keyword?

  • I already said - 1. SQL query from Sync Data Extension(DE) to an ordinary DE. 2. Import Mobile Contacts from the above DE to a contact list. The status of MobileConnect Contact is active, the country code is 'HK', the contact key is the PersonContactId. – daniel wu Dec 19 '17 at 6:13
  • And what about a keyword subscription? – Rain Dec 19 '17 at 8:07
0

Under Mobile Connect Administration, for your sending number, ensure Hong Kong is selected as an enabled country.

I assume you are formatting your mobile number in correct format.

Are you sending SMS using a From Name? Or Short Code or Long Code?

If sending as a From Name then also ensure your from name is registered with local aggregators. Your account executive will be able to assist you with this

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.