When I try to send an email with hindi words via Send Email button in email related list in Case, its allowing me to copy hindi the content and paste it in email body and subject [![enter image description here][1]][1]

but when send and receive it in gmail or any other email service. It only show the content like this "???????????????????????????????????????".

enter image description here

Anybody can help me out of this. How can I send an email with vernacular language.


2 Answers 2


I think you're email encoding settings are set to ISO-8859-1. This only supports latin languages (like English). If you change this to UTF-8 than you should have full support for Hindi and any other language.

This article explains it very well: https://help.salesforce.com/articleView?id=000005102&type=1

If you'd like to change the setting these are the instructions from the article. You need to change this at both the user records, and at the email template records for it to have full effect.

Navigate to Salesforce User Record
Salesforce Classic UI: Name | My Settings | Personal | Language & Timezone | Email Encoding
Lightning Experience UI: Click the User avatar in the upper right corner | Settings | My Personal Information | Advanced User Details | Click Edit - Select the required value for the 'Email Encoding' field

Navigate to Email Templates
Salesforce Classic UI:
Name | Setup |> Adminstration | Communicaton Templates | Email Templates (select the template) | Encoding
Lightning Experience UI:
Setup | Administration | Email | Email Templates | Select the template - Click Edit | Select the required value for the 'Encoding' field


Sorry I was wrong,This worked for me,

enter image description here

enter image description here

Symbols and special characters show up in emails sent via Salesforce https://help.salesforce.com/articleView?id=000175689&type=1


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .