Everytime I try to login to salesforce, it takes me to the intermediary ADFS login page, wherein I put my Active Directory credentials. This flow is perfect wherein I login from outside the network, but when I am already in the network, should'nt Salesforce log me in directly?Is there any setting I am missing?


The automatic login depends on your ADFS settings, as well as your browser's settings.

First, on the ADFS server, you need to enable Windows Login (Also known as "Integrated Windows Authentication" or "IWA" for short) as an option. Note that this mode may not be compatible with Salesforce1 on Apple devices (I haven't tested this in the past two years or so, so please feel free to try it out). To do this, you need go to in to the Authentication or Authentication Policies dialog and enable "Windows Authentication." Please refer to the ADFS documentation if you have trouble finding this.

Second, your browser must be configured to automatically log in, which will be different for Internet Explorer, Firefox, and Chrome. You'll want to read the documentation for your specific browser in order to enable this. Internet Explorer should use IWA by default, Firefox needs to be enabled manually, and Chrome may decide to do so based on your Internet Explorer settings. You'll need to check the documentation for your specific browser. However, this won't work at all until ADFS has already been configured to use IWA, and you've restarted the service.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.