0

I have created an email that contains a link to redirect users to a landing page. The users are required to enter their details and so the data is being upserted into a data extension using smart capture.

I am passing the subscriber key to the landing page and the data extension has a field that stores the subscriber keys of the users.

The issue here is that when a user updates the landing page and submits it, instead of updating the relevant record in the data extension a new record is created with the same key and a ','(comma) appended to it. Eg- if the key was '1234' the new record key is '1234,'. If the user updates the details again the new record is updated as expected.

Any thoughts as to why the ',' is getting appended to the key?

My email has the below Amp script:

%%[
var @skey
set @skey = AttributeValue("_subscriberkey")
SET @URL = ConCat('http://url/testpage?key=',@skey)
]%%

Below is the change to the html generated in my landing page:

<b>Hello %%= RequestParameter('key') =%%</b>
<br />

<div>
<b>LastName</b>
</div>

<div>
<input type="text" maxlength="80" name="LastName" id="LastName" value="" size="75" /> 
</div>

Under the processing tab, the action selected is 'Upsert to Data Extension'.

The users can change their last name from the landing page.

  • 1
    Can you share your code so that community can help you, without code difficult to help where it got be wrong . – NITHESH K Nov 20 '17 at 7:51
  • 1
    Can you check if the subscriberKey from the email is not getting passed with an extra comma? – Praveen Kumar Bandi Nov 20 '17 at 9:24
  • Please provide the code related to the collection of the key as well as the input that holds the subscriberkey. If you could provide the whole form (AMP and HTML), that would be even better. – Gortonington Nov 20 '17 at 13:48
0

You're actually passing two subscriber keys, which results in the comma-separated list of values for it.

The fix is to not append the subscriber key in the URL to the landing page. It's included in the send context already.

The email code should be this:

<a href="%%=redirectto("http://url/testpage")=%%">link</a>

In your page, all you need is this:

%%[

var @subscriberKey
set @subscriberKey = RequestParameter("_subscriberkey")

]%%
<b>Hello %%=v(@subscriberKey)=%%</b>
  • I tried this solution but the output is "Hello <blank> " . – user51241 Nov 22 '17 at 6:19
  • Did you click from a sent email? – Adam Spriggs Nov 22 '17 at 12:38
  • Yes. The sent email has a link clicking on which takes the user to a landing page. The user updates the details and submits. This updates the data extension. For every user who does this, first a record is inserted into the data extension with a comma appended to the subscriber key and then the update happens to this record only (the one with the comma). – user51241 Nov 23 '17 at 7:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.