0

I have a workflow rule on Lead:

IF 
( 
OR 
( 
ISCHANGED(Estimated_of_Advisors1__c), 
ISCHANGED(Estimated_of_Advisors2__c), 
ISCHANGED(Estimated_of_Advisors3__c), 
ISCHANGED(Estimated_of_Advisors4__c), 
ISCHANGED(Estimated_of_Support5__c) 
), 
true, 
false 
)

For whatever reason, when I change one of those fields, it's not executing the workflow. I tested this was the case because I created a simple email alert that should be firing off at this point and I never received the email after checking to make sure that the Deliverability was set for 'All Emails'. I initially discovered this issue because a field update was not firing when I expected. Anyone have any ideas?

  • Figured it out.... the field update didn't like to count null values as 0. I had to explicitly check for it with an if statement. – dphil Nov 15 '17 at 17:46
  • 2
    The IF statement isn't necessary, by the way: OR ( ISCHANGED(Estimated_of_Advisors1__c), ISCHANGED(Estimated_of_Advisors2__c), ISCHANGED(Estimated_of_Advisors3__c), ISCHANGED(Estimated_of_Advisors4__c), ISCHANGED(Estimated_of_Support5__c) ) – sfdcfox Nov 15 '17 at 17:47
0

Turns out that the email alert didn't want to fire for some reason but the real issue was with the Field Update. It didn't like me attempting to add null values together and when that happened it would simply not finish the field update. I changed those to do:

IF(ISNULL(NumberField1__c), 0, NumberField1__c) + IF(ISNULL(NumberField2__c), 0, NumberField2__c) 
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.