1

I am creating a text message in which i need a ® (Registered) symbol. I tried using the %%=char(169)=%% where 169 is the ASCII code for the registered symbol. But by using this I get the response:

there was an error processing your request

Can someone please suggest how to add registered symbol to text message. Also please advise if I can superscript the registered symbol.

Working Version:

Thank you for your request. Here is a link to download the XXX Mobile App.%%=char(10)=%%
iOS: http://apple.co/XXX%%=char(10)=%%
Android: http://xxx/xxx

Not Working Version:

%%[
SET @Reg = Char(174)
SET @message = Concat("Thank you for your request. Here is a link to download the XXX",@Reg)
]%%
%%=v(@message)=%% Mobile App.%%=char(10)=%%
iOS: http://apple.co/XXX%%=char(10)=%%
Android: http://xxx/xxx
3

I have come across this situation before where MobileConnect Outbound SMS wouldn't respect the spaces and I guess your reg trademark is related to same issue.

The workaround this is by using the ASCII characters within the SMS. Here is the table of the ASCII characters.

Also I'd use the AMPscript Char that returns the ASCII character specified by the ASCII character code in the first parameter.

Example:

%%[
SET @Reg = Char(174)

SET @message = Concat("This is a sample SMS to check the registered symbol.",@Reg)
]%%
%%=v(@message)=%%

Note: Superscript is part of the html tag and is not supported in SMS format.

Here is the screenshot enter image description here

| improve this answer | |
  • Above solution does not work. i get the same error message response. – kunal gidwani Nov 14 '17 at 19:00
  • @kunal I have test this myself in MobileConnect and I didn't face any issue. Could you please explain more on how you're testing the SMS? – Brad Sapkota Nov 15 '17 at 21:00
  • i am sending the keyword to the short code and getting an a reply 'there was an error processing your request'. When i remove the registered trademark from the sms and try again i get the desired message – kunal gidwani Nov 16 '17 at 22:29
  • @kunalgidwani Is there any chance you can update your post with the actual code you're using in the sms? – Brad Sapkota Nov 16 '17 at 22:44
  • Updating the code above – kunal gidwani Nov 16 '17 at 22:50
0

Only some country/code combos support the use of non-GSM characters. Most only support GSM 7 bit alphabet characters - the registered Mark isn't one

https://en.m.wikipedia.org/wiki/GSM_03.38#GSM_7-bit_default_alphabet_and_extension_table_of_3GPP_TS_23.038_.2F_GSM_03.38

According to Marketing Cloud documentation

You can only use GSM 3.38 and UTF-16 characters in SMS message content.

You could try : 0x00AE However if your country/code doesn't support it then you are stuck

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.