1

I'm using the Napili template in my community and I pulled in the Article Content Component to use on my release notes page. The problem is that the content/body of the article is not showing when the component renders (image below). The content is a custom rich-text field that I created since Knowledge Articles don't come with a standard content/body field.

Any ideas how to get this working?

enter image description here

ANSWER: If you're trying to "hard code" a specific article such that it shows on the page you'll want to use the KnowledgeArticleVersionID and not the KnowledgeArticleId. We're using a specific article for announcements that is shown at the top of the home page. The easiest way that I've found to get to the KnowledgeArticleVersionId is enabling Lightning Experience, search for the article and click on the link. In the URL you'll see an Object Id that starts with "ka4" vs the KnowledgeArticleId starts with kA4 (capital 'A') grab this Id and paste into the Article Component. You'll need to repeat this process anytime you publish a new version of the article.

1

If you're trying to "hard code" a specific article such that it shows on the page you'll want to use the KnowledgeArticleVersionID and not the KnowledgeArticleId. We're using a specific article for announcements that is shown at the top of the home page. The easiest way that I've found to get to the KnowledgeArticleVersionId is enabling Lightning Experience, search for the article and click on the link. In the URL you'll see an Object Id that starts with "ka4" vs the KnowledgeArticleId starts with kA4 (capital 'A') grab this Id and paste into the Article Component. You'll need to repeat this process anytime you publish a new version of the article.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.