0

We've uploaded a product table with French product data. The characters came out as gobblygook and researching here I found that we should save the file as UTF-8. Doing this made the TXT file data appear correctly, but upon import the data was wrong.

Here's a sample from the TXT file:

Cette blouse à manches au coude est entièrement faite de polyester. Agrémentée d'une fermeture à glissière à l'arrière

and here's how it looks in the Data Extension:

Cette blouse à manches au coude est entièrement faite de polyester. Agrémentée d'une fermeture à glissière à l'arrière

Any ideas on what to try next?

  • 1
    Could you please refer to this post salesforce.stackexchange.com/questions/187266/… – Brad Sapkota Oct 24 '17 at 23:21
  • Are you using a Mac system? If yes then try with the encoding "UTF-8 with BOM" – Praveen Kumar Bandi Oct 25 '17 at 7:34
  • It took a few tries, but we got it. First, THANK YOU to @BradSapkota for the link provided above. What threw us for a loop is that importing the TXT file into a UTF-8 CSV file required an extra step in MS Excel to set the "FILE ORIGIN" to UTF-8 as well. As an FYI, we're using PCs, not Apple – George Rosedale Oct 25 '17 at 14:10
  • @george No worries. I am glad it helped. I am going to post the answer to this question. Could you please accept and up vote so it will others see the solution. Thank you – Brad Sapkota Oct 25 '17 at 21:15
2

Above question is similar from the original post which was answered by Markus. The post recommends File Encoding during the File import.

Reference:

Encoding for the Import:

File Encoding - Select the type of file encoding you want to use. If no type is selected, the system defaults to UTF-8.

(Source: Import into a Data Extension)

  • I don't see "File Encoding" as an option during the import process. I've tried every option available to launch an import (from DE record screen, from an Import Activity, in Contact Builder) and I never see it. Is this a user permission thing, is it deprecated or ??? – George Rosedale Nov 17 '17 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.