5

I'm following the official Salesforce example about Lightning Container Component usage (Released Winter'18 on API 41.0): (RealtyApp)

I get a message like this on console: enter image description here If I click on the link, I can see this app working in a new tab.

In the example, I see a manifest.json according to Specifying a CSP Level and no luck, still the same error testing all modes.

Also, I tried with Basic Example as well (GitHub Lightning Container Examples), but I have the same problem.

I'm using a Trailhead Org to test this example but I run out of ideas to figure out what is going on.

  • We just tried to follow the same example on our developer org and personal orgs and we got exactly the same problems, just trying to open the Realty Lighting page which comes out of the box in the Github repository. And just recently in a brand new org I found it's working. I deployed exactly the same Realty source code with jsforce-deploy and on a new one. So extrange having it not working on 2 orgs and on the third one not this Refused to display error but it working like a charm. Some light here would be really welcome SF... – robertovg Oct 23 '17 at 15:22
  • 2
    I can confirm the same issue. I believe the crux of the issue is that the container src is being served from: <custom-domain>.c.container.lightning.salesforce.com instead of <custom-domain>.lightning.salesforce.com. Changing the manifest does not affect this issue. – tagCincy Oct 23 '17 at 17:25
  • see the comment here for temporary workaround : salesforce.stackexchange.com/questions/206676/… – Mitesh Sura Mar 2 '18 at 16:16
0

At the moment, we don't know the origin of the problem. We have set a new organization and this component works now.

  • We still have the same problem with a new DE org (just signed up right now). Not sure where the difference is. – stomita Nov 14 '17 at 21:14
  • @stomita were you able to discover reason for why this was occurring? I am also encountering similar issue in a sandbox, though it works fine in a DE (as this answer suggests) – Roger Mitchell Aug 8 '18 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.