0

I am using git and force.com migration tool for deploying code into sandbox. It was working correctly for many days (including todays morning) until git automatically started to 'Auto packing the repository for optimum performance'. (I think it might use git gc command). After that 'sf:deploy' command in my build.xml file is not working. The following error is generated each time:

Failed to submit request to https://xxx.yy00.my.salesforce.com/s ervices/Soap/m/39.0/000000000000000 for user (my username). Error: {http://schemas.xmlsoap.org/soap/envelope/}Server - java.lang.UnsupportedOperationException: getInputStream null data source. Error Id: 1995815151-21921 (-1035193292)

Anyone has spotted similar error? Do you know what to do to fix the problem?

1

I don't think the git packing should have affected that so likely something else in play. Have you tried any of the following?

  1. Checked out an older commit in git that you knew to be working
  2. Used a new version of the migration tool (I see you're using one thats targeting an older API)
  3. Tried a small deployment to a different org from that same repo to check if any weirdness in your org?
| improve this answer | |
  • Thanks for help! That was a really weird one... I was searching for the fix around deployment itself not the commit. I've tried to deploy another commit - it worked! Ok, so I've tried checkout again to the spoilt branch and deploy it - and unexpectedly it worked! xD – Łukasz Kojzar Oct 20 '17 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.