2

I am trying to follow this documentation

I tried to install several features:

  • 'com.salesforce. service:servicesdk:208.4.0'
  • 'com.salesforce.service:chat-ui:1.1.1'
  • 'com.salesforce.service:chat-core:1.1.1'

I've set the salesforce maven url:

repositories {
    mavenLocal()
    jcenter()
    maven {
        url "https://salesforcesos.com/android/maven/release"
    }
}

But I keep getting the same error.

Error:Failed to resolve: com.salesforce.service:servicesdk:208.4.0

I'm not under any proxy.

Is the documentation out of date? Or is there a way to get the SDK without Gradle?

  • Hi Alex, I am also facing the same issue. Could you please tell how you came out of this? – hashcoder Dec 19 '17 at 8:40
0

The documentation you linked is up to date and is working for me. I verified by using the sample app at the link below. Can you clone that and see if it resolves your dependencies. https://github.com/forcedotcom/ServiceSDK-Android

I would suggest changing line 38 of the apps build.gradle from compile 'com.salesforce.service:servicesdk:+' to compile 'com.salesforce.service:servicesdk:208.4.0' to ensure you always use the same version of the sdk.

I will also note that the full gradle build will fail because there are some lint warnings becuase abortOnError is on. This will be updated in the future.

https://github.com/forcedotcom/ServiceSDK-Android

  • Hi Steve, I am also facing the same issue. Peviously this was working (like 3 months ago), but now the mave repo is not available. Could you please help on this? – hashcoder Dec 19 '17 at 8:41
  • Hi hashcoder, I just checked the maven repo and everything appears to be working for me. Can you confirm you are still having the problem and if so post the version you are trying to use. Also confirm the maven repo in use is 'salesforcesos.com/android/maven/release' – Steve T Dec 20 '17 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.