2

With Winter18, elements sizes in compound forms are overridden to something like slds-size--1-of-1, despite the slds-size specified.

For example, this code from the SLDS Documentation used to work, but doesn't work anymore:

<div class="slds-form-compound"> 
  ...
  <div class="slds-form-element slds-size--1-of-3">

This doesn't work either:

<div class="slds-form-compound"> 
  ...
  <div class="slds-form-element">
    <div class="slds-size--1-of-3">

With Winter18 overrides on our sizes, some elements don't even appear in modals.

Is it a Salesforce bug? Does it happen to you as well? How can we solve?

  • Spot on! I ran into the same issue with modals this morning after winter’18 live. – javanoob Oct 16 '17 at 16:28
0

I run into the same problem and unfortunately it's on one of customer community page so can't wait for salesforce to fix it. We simply orverride the CSS with something like: -

.THIS .slds-form-element.slds-size--1-of-1 {
    width: 50% !important;
}
  • Do you use slds from a static resource? – ctrl-z Oct 19 '17 at 8:41
0

We have the same problems on a customer visible side, what makes it really bad.

I use this as a temporary solution as our components are grouped as row-element as well:

.THIS .slds-form-element__row {
    width: 49%;
}

Would be great to get an official statement from Salesforce, if something in their CSS was changed?!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.