Went to try and use SFDX tonight (it was working a few days ago) and received the following

Plugin "salesforcedx" v41 or later may only be installed in a v6.0.0 or later CLI. 41.3.0

I tried to run sfdx update and received

sfdx-cli: Updating salesforcedx@latest to 41.3.0...Plugin "salesforcedx" v41 or later may only be installed in a v6.0.0 or later CLI. 41.3.0


▸ Error installing plugin salesforcedx

I uninstalled the salesforcedx plugin and tried to reinstall it and received same error...

Any ideas on how to recover or am I dead in the water?

  • Just tweeted and wade the product owner said they are looking into this issue !!! Oct 15, 2017 at 0:54
  • I am wondering if there is another url where every version is maintained. Oct 15, 2017 at 0:55
  • Can you tell us the version of your CLI? Type: sfdx version Oct 15, 2017 at 1:03
  • 3
    I’ll write this up shortly as an answer, but I believe you were running the CLI for the pilot (very old). It would have been version 5.6, and is not updatable to version 6. We told everyone at the beginning and end of pilot they’d have to uninstall the pilot bits. Sorry for the challenge. Oct 15, 2017 at 1:11
  • 1
    Welcome @wade to Salesforce,Stackexchange.com .Appreciate your time here! We have all the questions related to DX with tag salesforce.stackexchange.com/questions/tagged/salesforcedx Oct 15, 2017 at 1:12

2 Answers 2


If you downloaded the Salesforce CLI during the Salesforce DX Pilot, you likely have version 5.6.X. Unfortunately, this is not upgradable to version 6 of the CLI. You'll have to uninstall. When you go to uninstall, be aware that it was using heroku in the binary path name, so you'll need to use this script from Dave Carroll: uninstall Salesforce CLI from Pilot.

If you have version 5.7.X or higher, you should be able to upgrade by running sfdx update.

Hope this helps!

  • I get permission denied when trying to run that script on the heroku stuff. The heroku version is heroku-cli/5.6.22-f9533ba (darwin-amd64) go1.7.3 sfdx. I downloaded and installed the current Heroic CLI over top, will that suffice?
    – Eric
    Oct 15, 2017 at 16:08
  • 2
    Yes, these commands need to be run with sudo. Oct 15, 2017 at 17:38
  • Also, the salesforcedx plugin is now "core" plugin, meaning it does not need to be installed separately.. Oct 15, 2017 at 18:01
  • Fyi, we were able to uninstall the sfdx pilot binaries and install the latest version without removing the heroku binary or using sudo so that may not be necessary for everyone ... Oct 17, 2017 at 19:00

Equivalent instructions for Windows:

  1. Uninstall SFDX CLI
    enter image description here
  2. For good measure, uninstall the Heroku CLI as well enter image description here
  3. delete %HOMEPATH%\.config\sfdx directory if it exists
  4. Reinstall from https://developer.salesforce.com/tools/sfdxcli
  5. Trigger the CLI to check for updates - sfdc update enter image description here
  • 1
    If sfdx hangs on windows 7, you can delete the entire sfdx directory under <home directory>\appData\Local\sfdx. Then run sfdx update and it will re-download the latest version.
    – willard
    Oct 18, 2017 at 21:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .