0

My domain is setup.
Auth provider is setup. For Authentication Configuration only Auth Provider is selected for Auth Service.
When I go to https://mydomain.my.salesforce.com/ I'm presented with Auth Provider's login screen. When I login I'm in Salesforce. So far so good.
Now, when I log out by default I'm redirected to https://mydomain.my.salesforce.com/ . When I'm on https://mydomain.my.salesforce.com/ login process is starting. Because I'm already logged in with Auth Provider it does not ask me about whether I want to login or not.

The solution is to set specific logout url. But it will result in being redirected somewhere else.
Another option is to make Login Page enabled for Auth Services.
I'm curious, is there a parameter in domain url to prevent auto login?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.