3

I have a lightning component that was created on API 40, but now I want it to use the new lightning:tree. The sandbox I work on is in preview mode for Winter'18, API 41 is apparently available.

However I do get the error message

This page has an error. You might just need to refresh it. Component API
version is too old: 'markup://c:QuickTextList' must be set to API version
'41' or later to use component 'markup://lightning:tree' 
Failing descriptor: {markup://c:QuickTextList}

Okay, sure, but I have changed the API-version of the bundle to 41: image showing the QuickTextList to have API 41,0

I also set the API-version of all Lightning components in use to 41, although the offending part is only in the QuickTextList component. Additionally all Apex that is remotely involved is set to API 41.

Is there anything I am overlooking?

1

This issue affected me as well. It was extremely frustrating, but the fix for me was simple.

Situation

I was receiving an error complaining that I could only use the new lightning:recordForm component in a component of API version 43 or above. I changed my version to 43 on everything, but the error persisted, even in my test app. I tried moving my markup and code to a new component, but that didn't work either.

Solution

  1. remove all markup (other lightning components) from the component, except my aura attributes and the new lightning:recordForm component
  2. click Save
  3. paste markup back into the component, supposedly creating the same situation as before
  4. click save

It worked for me, hopefully it will help someone else too.

0

Multiple references to older version may need to be updated. Update version in Component, Controller and Application, then refresh application. If that doesn't work wait a few minutes and try again. Problem solved!

  • Unfortunately not. The workaround that worked for me was to leave the version of everything as it is, and then just create a new component - QuickTextList2 in this case. All other potentially involved components, such as the Controller, did not need to change their API version. What I had tried was to set the API version of EVERYTHING in the project to 41, deploy that but even over night - no deal. – Florian Heer Nov 2 '17 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.