A few of the users in the system have hit an interesting error after implementing some functionality around the platform cache. I received the emails as the owner of the files, but I was not able to replicate this.

I have tried triggering an update on the case record from different places (UI, dev console, IDE - exec anon) without success. I have also tried performing an update from @future method, as well as running unit tests, without being able to replicate this.

A case has been raised with Salesforce and I haven't heard anything yet, so I thought I'd post this here. Hopefully another pair of eyes can help me identify what potentially can cause such thing.

The only close thing I could find online was this, but again as mentioned I tried using @future and it works.


This happens very random:

Apex script unhandled trigger exception by user/organization: USERID/ORGID
Source organization: ORGID (null)
CaseCommonTrigger: execution of BeforeUpdate

caused by: System.UnexpectedException: Salesforce System Error: 1295024496-13000 (1641176973) (1641176973)

Class.cache.PlatformCacheDelegateWrapper.getOrgPartitionDelegate: line 19, column 1
Class.cache.OrgPartition.<init>: line 20, column 1
Class.cache.Org.getPartition: line 20, column 1
Class.CacheManager: line 38, column 1
Class.Utility.getsObjectRecordTypeNames: line 88, column 1
Class.CaseTriggerHelper: line 45, column 1
Class.CaseTriggerHandler.execute: line 43, column 1
Trigger.CaseCommonTrigger: line 10, column 1

The code related to the above is as follows:

Trigger.CaseCommonTrigger: line 10


Class.CaseTriggerHandler.execute: line 43

private static CaseTriggerHelper helper;
public static void execute()
    helper = new CaseTriggerHelper(); // <--

Class.CaseTriggerHelper: line 45

public static Map<Id,String> recordTypeMap = new Map<Id,String>();
    recordTypeMap = Utility.getsObjectRecordTypeNames(String.valueOf(Case.getsObjectType())); // <--

Class.Utility.getsObjectRecordTypeNames: line 88

String cacheKey = CacheManager.normaliseCacheKey(CacheManager.CacheKey.UTILITY_OBJECT_RECORD_TYPES, objName);

Class.CacheManager: line 38

private static Cache.OrgPartition orgPartition;
static {
    orgPartition = Cache.Org.getPartition('local.PlatformCache'); // <--

Essentially, Cache.Org.getPartition('local.PlatformCache') happens to occasionally fail for no apparent reason (as far as I can tell).

Any thoughts on what might be causing this, or something that I should try in order to replicate the problem?

  • well - Salesforce System Error: 1295024496-13000 (1641176973) (1641176973) is a gack so raising a Case w/ SFDC was the right call – cropredy Oct 10 '17 at 13:51

I finally got a proper response from SFDC support saying that there is a known issue (P1). There must be a set of specific circumstances in order to reproduce this. I've also tried a bunch of other things like time based workflows, process builder etc. This isn't a proper answer, though once I find out the exact steps and a workaround, I'll update it.

If you've hit this error, click the above link, tick that it affects you and let's just wait for SFDC to resolve it.

| improve this answer | |
  • I have seen the same error and the stack trace looks the same as the one you mentioned in the question. The final stack trace leads to cache.org.getPartiton() method. Were you able to find any solution or workaround for this? – Nihar Oct 17 '17 at 17:16
  • At this point in time there are no reproduction steps, therefore Salesforce have flagged it as a low priority. Just follow that known issue record for updates – Boris Bachovski Oct 17 '17 at 22:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.