0

Updated the Docusign for Salesforce managed package in Salesforce from version 6.2.1 (showing 6.8) up to the current 6.8.2. After doing so I'm now receiving the following when trying to access Docusign.

Final variable has already been initialized An unexpected error has occurred. Your solution provider has been notified. (dsfs)

As an admin of the org I also get the APEX error email with the following pertinent details:

Visualforce Page: /apex/dsfs__DocuSign_Admin


caused by: System.FinalException: Final variable has already been initialized

Class.dsfs.PlatformPermissionSetService.<init>: line 32, column 1
Class.dsfs.ServiceLocator.getPermissionSetService: line 72, column 1
Class.dsfs.DocuSignConfiguration.loadConfig: line 366, column 1
Class.dsfs.DocuSignConfiguration.initConfiguration: line 338, column 1
Class.dsfs.DocuSignConfiguration.getInstance: line 214, column 1
Class.dsfs.ConfigurationService.<init>: line 32, column 1
Class.dsfs.ConfigurationService.<init>: line 20, column 1
Class.dsfs.ServiceLocator.getConfigurationService: line 60, column 1
Class.dsfs.ServiceLocator.getConfigurationService: line 50, column 1
Class.dsfs.AdminManager.findAdminDetails: line 12, column 1
Class.dsfs.AdminController.<init>: line 41, column 1

As a salesforce developer I see this as an error in the managed package code wherein they are trying to assign a value to an already initialized final type variable, likely related to a caching of Permission Set information.

I have already uninstalled the app in one of our sandboxes and reinstalled, this did not fix the error.

I installed this in a developer org that has not had the app installed before and it pulls up the VF page without issue.

Assuming this is related to my org but can't find anything in my control to manipulate. Unable to inspect the protected custom settings related to the app.

Cross posted from Stack Overflow tagged to docusign.

0

I have also facing similar kind of issue for my custom object. I have tried the below code and it worked. You can take a look to the URL. ids is the docusign envelop id and then id appended my custom quote object. Now the url is working.

var url="/apex/dsfs__DocuSign_editenvelope?DSEID="+ids+"&nw=0&rc=&SourceID={!Quote__c.Id}";

1
  • My buttons were missing the nw=0 that is in your URL. Adding that does not correct the error, unfortunately. – Anthony Heber Nov 2 '17 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.