0

I created a new custom object and created an account and a contact which are required fields on that object. I also created an instance of the custom object and saved it. The problem I am having is that when I add the path or the highlights panel to a record page in the lightning app builder, each of them display the message "No data available to display component contents." Do you have any idea why that might be happening? My custom object is deployed, my path is active, and it has the first step all filled out.

Edit - View In Lightning: Edit - View In Lightning: When I was just an admin without Lightning permissions the view in app builder showed the specific error I mentioned. After I gave myself Lightning permissions it now shows up blank, although the highlights panel now has info.

I have only filled out the first step, but this is what my path setup looks like:enter image description here

  • Did you set up path for the org? – Rao Oct 6 '17 at 21:34
  • I thought that clicking on the green activate button was setting it up. Is there something else I have to do? – AstroLovesCodey Oct 6 '17 at 21:37
  • Click on the path standard component you should see a Set Up Path – Rao Oct 6 '17 at 21:47
1

I just figured out the problem! I had only one record type, master. I was having trouble with something else and thought adding a specific record type might help so I added anther called sales. At that point I deactivated the master one. Well, I did not assign the sales record type to the system admin profile. I went back and checked activate on the master path and it now appears! Thanks @Rao for putting the idea about checking activation status in my head!

0

1) Did you setup path for this object?

2) If you go to edit page on the custom object and click on the path component, you will see configure the path in the right side panel.

Note: If you do not see your custom object as an option when setting up path, create a picklist for the custom object and the picklist that shows available objects to create path will automatically show your custom object.

enter image description here

  • I have already done that. – AstroLovesCodey Oct 6 '17 at 21:59
  • did you activate the path? when you setup the path the last step shows active/inactive did you choose the active radio button ? – Rao Oct 6 '17 at 22:00
  • Yes, it is marked as activated. Please see the pictures I added above. – AstroLovesCodey Oct 6 '17 at 22:05
  • Do you have record types and could be be possible that you are looking at a record with master record type and the path is setup for another record type? can you post the path setting page which shows active/related record type etc.. – Rao Oct 6 '17 at 22:07
  • 1
    Ha! You came up with the same answer as I was typing mine out! Great minds think alike! :) – AstroLovesCodey Oct 6 '17 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.