3

I successfully installed Salesforce DX on Windows but I cannot use it because of proxy issues.

I already configured the environment variables as described at: https://developer.salesforce.com/docs/atlas.en-us.sfdx_setup.meta/sfdx_setup/sfdx_setup_install_cli_firewall.htm but I encounter the following errors:

sfdx update
! Get https://cli-assets.heroku.com/branches/sfdxstable/manifest.json: Proxy Authentication Required

sfdx force
Installing required plugins for force...
!    Error installing package.
!    npm ERR! Windows_NT 6.1.7601
!    npm ERR! argv "C:\\Program Files (x86)\\sfdx\\lib\\node.exe" "C:\\Program Files (x86)\\sfdx\\lib\\npm\\cli.js" "install" "salesforcedx"
!    npm ERR! node v6.9.5
!    npm ERR! npm  v3.10.10
!    npm ERR! code ECONNRESET
!
!    npm ERR! network tunneling socket could not be established, cause=socket hang up
!    npm ERR! network This is most likely not a problem with npm itself
!    npm ERR! network and is related to network connectivity.
!    npm ERR! network In most cases you are behind a proxy or have bad network settings.
!    npm ERR! network
!    npm ERR! network If you are behind a proxy, please make sure that the
!    npm ERR! network 'proxy' config is set properly.  See: 'npm help config'
!
!    npm ERR! Please include the following file with any support request:
!    npm ERR!     D:\Utilisateurs\XXXX\AppData\Local\sfdx\plugins\npm-debug.log
!
!    Try running again with SFDX_DEBUG=1 to see more output.

I tried both with and without the authentication part for the following environment variables:

npm config set https-proxy
npm config set http-proxy
npm config set proxy
set HTTP_PROXY
set HTTPS_PROXY

Any suggestions? Are there specific IPs or domains to open at the proxy level ? Should we wait for the offical release?

  • did you manage how to fix this issue? – Bogdan K Jun 4 '18 at 10:09
2

hey did you try setting proxies for npm like this:

npm config set https-proxy https://username:pwd@proxy.company.com:8080
npm config set proxy https://username:pwd@proxy.company.com:8080
npm config set sslVerify false
npm config set strict-ssl false

then creating a Environment variable

HTTP_PROXY >> https://username:pwd@proxy.company.com:8080

note: not mandatory to set proxy as https as above it can be http as well same goes with username your proxy can be like http://proxy.company.com:8080 for all above variables

0

@djmat - From the error it looks like you have not provided your proxy credentials. Did you try providing that? Use the format below: Replace the username/password/port with appropriate values.

npm config set strict-ssl false
npm config set proxy http://yourusername@username.com:yourpassword1@proxy.proxy.com:8080
npm config set https-proxy http://yourusername@username.com:yourpassword1@proxy.proxy.com:8080

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.