1

I recently uninstalled a managed package that had a lot of custom code built on top of it.

Some of the custom work is triggers. These triggers never had complete coverage as far as I know. Furthermore, the test classes for them were contained in a generic test class file that I deleted along with the managed package.

So effectively at the same time, I was able to make these triggers inactive and delete the managed package. I'm now left in a position where the Inactive triggers are still showing in the Production org and counting against code coverage but I cannot see them anywhere other than in the Dev Console code coverage list results. They are also written around now non-existent sObjects so I'm not even sure I could write and deploy a test class to cover them.

I need to delete these triggers out but I have no way of accessing them. If I download a full copy of the Prod org in an IDE these triggers are not included.

Has anyone had an experience like this where a trigger is included in code coverage but cannot be accessed in the web browser or through an IDE? Inactive Triggers with No Coverage

Trying to Access a Trigger in Prod

Trigger Viewed in a Sandbox

2
  • So, do you just need to know how to delete the triggers from your production org? What is it that you need assistance with?
    – Mark Pond
    Commented Oct 2, 2017 at 3:40
  • Yes, I need to know how to delete them from the production org. They are inactive (I believe) and they are showing up in my code coverage but I cannot see them listed. Additionally, when I download the entire Prod org in an IDE they are not included.
    – j.sweet
    Commented Oct 2, 2017 at 3:43

0

Browse other questions tagged .