0

I have created a 3 level dependent picklist chain:

  1. Reason 1
  2. Reason 2
  3. Reason 3

Where 1 determines 2, and 2 determines 3.

The problem is, I have deployed this from our Dev org to our Test org, which worked just fine. However, after making additional changes to dependencies, those changes do not appear when they are deployed from Dev to Test. I tried:

  1. Salesforce Deployment Tool
  2. Change Set via web UI

In both cases above, I including the dependent and controller picklists, as well as the global picklist (Picklist Value Set) in the deployment package.

One more variable, the "Reasons" are all the same, where the values are sourced from a global picklist (Picklist Value Set).

I was able to delete the Reason 2 and Reason 3 fields in Test and redeploy and it worked fine. It is only when you try to deploy changes that it won't deploy the controlling/dependent field configuration.

What do I need to do to deploy my changes to controlling and dependent picklists?

  • Ever find a solution? I'm seeing the same behavior summer '18. – tggagne Jul 25 '18 at 18:13
  • If memory serves, I don't believe so. I believe I just made the changes by hand in production. – Swisher Sweet Jul 25 '18 at 22:16
  • 2
    I did a test and discovered the picklist metadata only makes additive changes and not destructive changes. So it'll add new dependent values but not remove them. plus.google.com/+ThomasGagne/posts/V4vWEVi1VgD – tggagne Jul 27 '18 at 2:42
0

Are Reason 1,Reason 2 and Reason 3 picklist values are coming from any globale picklist?If yes, please involve your global picklist in the deployment

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.