4

I would like to use the Adobe PhoneGap Build service to build a version of a hybrid application for each mobile platform supported by PhoneGap Build. The problem that I've noticed is that even in the newest version of the Salesforce Mobile SDK it still only uses Cordova 2.3.0. According to the settings menu on PhoneGap Build, the latest version of Cordova is 2.9.0 and the earliest version it supports building for is 2.5.0.

Does anyone have experience doing this and would be willing to point me in the right direction?

3

You'll need to build your apps locally for now. PhoneGap Build doesn't have support for the SmartStore or OAuth plugins included with the Salesforce Mobile SDK. Once the SDK is updated to a newer version of cordova, perhaps the cordova plugins could be submitted as PhoneGap Build plugins.

| improve this answer | |
  • Ah, that is unfortunate, but I appreciate the answer. It would seem that a Mac and Xcode are required to build for iOS in this case. – jsnbdly Nov 6 '13 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.