2

I have created a lightning component. I drag the custom Lightning component from the left side to the desired section of the Opportunity Record Page using Lightning App Builder. I save the changes and activate the new changes. I open the opportunity page my component is there at desired location. But when I click Create a Task under Activity Tab as shown below enter image description here

I am getting the following error

This page has an error. You might just need to refresh it. First, would you give us some details? (We're reporting this as error ID: 132418344)

Uncaught Assertion Failed!: Descriptor for Config required for registration : undefined [Error creating components in runtime_sales_activities:composerPageBlockSectionEdit] Callback failed: serviceComponent://ui.force.components.controllers.recordLayoutBroker.RecordLayoutBrokerController/ACTION$getLayout throws at https://My-Test-Domain-dev-ed.lightning.force.com/auraFW/javascript/ra1ulv_rPNMd9ZOOtLxgew/aura_prod.js:8:15 BH.log()@https://My-Test-Domain-dev-ed.lightning.force.com/auraFW/javascript/ra1ulv_rPNMd9ZOOtLxgew/aura_prod.js:214:393 BH.assert()@https://My-Test-Domain-dev-ed.lightning.force.com/auraFW/javascript/ra1ulv_rPNMd9ZOOtLxgew/aura_prod.js:211:43 $.B.assert()@https://My-Test-Domain-dev-ed.lightning.force.com/auraFW/javascript/ra1ulv_rPNMd9ZOOtLxgew/aura_prod.js:825:279 U.bc()@https://My-Test-Domain-dev-ed.lightning.force.com/auraFW/javascript/ra1ulv_rPNMd9ZOOtLxgew/aura_prod.js:530:88 U.vb()@https://My-Test-Domain-dev-ed.lightning.force.com/auraFW/javascript/ra1ulv_rPNMd9ZOOtLxgew/aura_prod.js:556:41 U.Od()@https://My-Test-Domain-dev-ed.lightning.force.com/auraFW/javascript/ra1ulv_rPNMd9ZOOtLxgew/aura_prod.js:534:290 Object.createComponentFromConfigWithErrorHandling()@https://My-Test-Domain-dev-ed.lightning.force.com/libraries/force/componentLibrary/components.js:6:20

enter image description here

I don't know whats is going wrong.

  • I already have some weird errors too when I had some errors in one my lightning components displayed in a lightning page. The errors raised didn't have anything related to the real error. Did you try to add a basic test lightning component with nothing more than a hello world inside the page? To check if it works? – Martin Lezer Sep 20 '17 at 6:39
  • @Martin Lezer I made a hello world component and It works fine? – ozil Sep 20 '17 at 7:43
  • What happens if you insert your custom component inside an empty Lightning application? – Martin Lezer Sep 20 '17 at 7:50
  • @MartinLezer I inserted in empty lightning app it works fine – ozil Sep 20 '17 at 8:59
  • Do you use any external API's which are not listed as compatible with the Lightning Locker Service? – Martin Lezer Sep 20 '17 at 9:05
0

OK, I found the problem, issue was with my external library files, salesforce doesn't allow to add prototype toarray data type. Removing that function from prototype and making it a separate function resolve my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.