4

I'm trying to override the "view" action of a custom object, but unable to do so (and getting some odd error messages in the process.)

When the screen first appears, none of the three radio buttons are checked. If I try to select "no override" then I get the following with no additional clarification:

enter image description here

When I try to override with a lightning component (which is ultimately what I'm trying to achieve) then I get the message:

There were custom validation error(s) encountered while saving the affected record(s). The first validation error encountered was "Large is not a supported form factor.".

Any idea as to what's going on here and how I might fix it?

6
  • The configuration xml file might be corrupted or may have bad values, check this documentation. Try creating another lightning component and use it for override.
    – Raul
    Sep 15, 2017 at 10:50
  • @RahulSharma No joy I'm afraid - I already tried editing the XML file manually to add an action override there (and checked there was nothing odd present as well), but I get exactly the same behaviour.
    – berry120
    Sep 15, 2017 at 10:54
  • Have you try using a newly created component for override?
    – Raul
    Sep 15, 2017 at 10:57
  • @RahulSharma Yes, the same behaviour occurs no matter what component I use.
    – berry120
    Sep 15, 2017 at 11:26
  • @berry120 I got the same error today and I landed up here. I found that this occurs when I try to do it in the lightning experience (LEX). When I try to override the view action using the Lightning Component Bundle in Classic, it works with out any issue. Hope this helps someone looking out a workaround in the future.
    – Karthik
    Oct 27, 2017 at 19:05

3 Answers 3

2

I encountered this on API v42.0 overriding the New Case action with a Lightning component, and ended up having to remove the <formFactor>Large</formFactor> section from the .object metadata. See this post for more details: Deployment - Error: You can't use the Large form factor with a Lightning component action override

1
  • 1
    +1 - not the issue I was having since this was before Spring '18 came out, but certainly looks like this can be caused by a number of different things!
    – berry120
    Feb 20, 2018 at 11:41
1

I found a solution to fix this issue. This is happening because you have a flexipage set as global org default overriding this setting.

Just do the following:

  1. Go to "Lightning App Builder".
  2. Edit the page that corresponds to your object.
  3. Go to "Activation..." and remove it as org default.
  4. Save and now you can set the visualforce override as usual.
1
  • Thanks for the tip - unfortunately this doesn't seem to be the issue in my org either though.
    – berry120
    Nov 14, 2017 at 16:23
1

Just try to save when clicking on Lightning Component or VF page and then save after clicking on no override. It reinitialize the action and the error message disappears

1
  • -1 isn't from me, but afraid that doesn't make any difference to the error message m end.
    – berry120
    Oct 22, 2017 at 11:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .