1

I have tried to enable the Winter 18 new Lightning Report Builder.

So I have added a permission set to my user that has Report Builder (Lightning Experience) permission.

After doing that - I cannot enter anymore the Reports tab or any report, and the Dashboards tab or any dashboard.

I always get this error:

Error in $A.getCallback() [Library include not defined: js://force.calendarLibrary.DateUtils] FK.Df()@https://myorgname.lightning.force.com/auraFW/javascript/N7IitgTrFKAhFRnZsZkeiA/aura_prod.js:406:97 V.Df()@https://myorgname.lightning.force.com/auraFW/javascript/N7IitgTrFKAhFRnZsZkeiA/aura_prod.js:579:43 IK.Vi()@https://myorgname.lightning.force.com/auraFW/javascript/N7IitgTrFKAhFRnZsZkeiA/aura_prod.js:407:396 V.Vi()@https://myorgname.lightning.force.com/auraFW/javascript/N7IitgTrFKAhFRnZsZkeiA/aura_prod.js:578:385 fJ.Hc()@https://myorgname.lightning.force.com/auraFW/javascript/N7IitgTrFKAhFRnZsZkeiA/aura_prod.js:258:400 V.Hc()@https://myorgname.lightning.force.com/auraFW/javascript/N7IitgTrFKAhFRnZsZkeiA/aura_prod.js:567:59 V.Bb()@https://myorgname.lightning.force.com/auraFW/javascript/N7IitgTrFKAhFRnZsZkeiA/aura_prod.js:583:323 V.tf()@https://myorgname.lightning.force.com/auraFW/javascript/N7IitgTrFKAhFRnZsZkeiA/aura_prod.js:559:368 l()@https://myorgname.lightning.force.com/libraries/force/componentLibrary/components.js:1:278 Object.h.createPanel()@https://myorgname.lightning.force.com/libraries/force/componentLibrary/components.js:2:15

enter image description here

So I have removed the permission, but still I get this error whenever I want to open a report or report tab or dashboard or dashboards tab, and cannot enter these pages.

This is a bug for sure, but what can I do to get rid of these errors?

0

Have you also enabled "Enable Lightning Report Builder (Beta)" in the "Report and Dashboard (User Interface) Settings" ?

Mind you on the Community, it was mentioned that it has not yet been rolled out to Sandboxes? https://success.salesforce.com/0D53A00003Erc5x

It is available in my pre-release org though, and working, after having turned it on, and assigning myself the permission

  • All my settings where ok, anyway - now it works and the problem is solved, I do not know what fixed this, maybe Salesforce fixed it on the background, but - I cannot use Lightning Report Builder - I get always the old report builder – Itai Shmida Sep 13 '17 at 5:19
0

Now it works and the problem is solved, I do not know what fixed this, maybe Salesforce fixed it on the background.

But still - I cannot use Lightning Report Builder - I get always the old report builder, I think I will ask a new question for that

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.